<!doctype html>
<!--[if lt IE 7 ]> <html lang="fi" class="ie ie6"> <![endif]-->
<!--[if IE 7 ]> <html lang="fi" class="ie ie7"> <![endif]-->
<!--[if IE 8 ]> <html lang="fi" class="ie ie8"> <![endif]-->
<!--[if IE 9 ]> <html lang="fi" class="ie ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--><html lang="fi"><!--<![endif]-->
<head>
  <title>Huawei rauhoittelee huolestuneita: Gmailia voi käyttää kuten ennenkin, tietoturvapäivitykset eivät lopu –​ 5 kysymystä puhelinkiistasta | Yle Uutiset | yle.fi</title>
  <meta charset="utf-8" />
  <meta name="description" content="Huawei vakuuttaa, että Googlen sovelluksia voi käyttää koko puhelimen eliniän ajan. Puhelinmyyjän ei tarvitse vastaanottaa virheetöntä puhelinta ja palauttaa rahoja, tulkitsee operaattoreita edustava Ficom." />
  <meta property="og:description" content="Huawei vakuuttaa, että Googlen sovelluksia voi käyttää koko puhelimen eliniän ajan. Puhelinmyyjän ei tarvitse vastaanottaa virheetöntä puhelinta ja palauttaa rahoja, tulkitsee operaattoreita edustava Ficom." />
  <meta property="og:url" content="https://yle.fi/uutiset/3-10793809" />
  <meta property="og:image" content="https://images.cdn.yle.fi/image/upload/w_1200,h_630,c_fit,q_80/13-3-10794153.jpg" />
  <meta property="og:type" content="website" />
  <meta property="og:title" content="Huawei rauhoittelee huolestuneita: Gmailia voi käyttää kuten ennenkin, tietoturvapäivitykset eivät lopu –​ 5 kysymystä puhelinkiistasta" />
  <meta property="og:site_name" content="Yle Uutiset" />
  <meta property="fb:app_id" content="147925155254978" />
  <meta property="fb:pages" content="170559451901,252166562460,291117849202,192534820828660,246415834930,141733389996,185521831442,127820652625,225930055836,182155748236,136798886342079,333763622448,312937363491,190153419756,300238829691,250842384819,366734725407,227515436637,116686841709805,355899633222,300809901605,166619556742075,492609065374,124877274234053,230483103705424,200984393268390,1651249601794906,107308025957314,173241277806,345732187153,183860797738,69675651064,164345690280744,1148642531826361,643517599029267,531270113605417,165217470246480,1380652225559559,509209759245250,113980165302836,351173836210,479683965433928,192230846527,1654755908077820,765596730168740,196737677052513,106560389371863,1724601357566118,50687535468,171726874124" />
  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@yleuutiset" />
  <meta name="viewport" content="width=device-width, initial-scale=1" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
  <meta name="apple-mobile-web-app-title" content="Yle Uutiset">
  <meta name="apple-mobile-web-app-status-bar-style" content="black">
  <meta name="google-site-verification" content="y4zRorMayuVdpTOEN1IAI9syO9dZE4rbV1k2vkb_Cms" />
  <meta name="theme-color" content="#007e96">
  <meta name="msapplication-navbutton-color" content="#007e96">
  <meta name="apple-mobile-web-app-status-bar-style" content="#007e96">
  <link rel="preconnect" href="//www.kaltura.com">
  <link rel="preconnect" href="//www.googletagmanager.com">
  <link rel="preconnect" href="//analytics-sdk.yle.fi">
  
  <script type="text/javascript" src="/uutiset/public/custom_components/modernizr.min.js"></script>
  <script type="text/javascript" src="/uutiset/assets/1.0.5753-header-bundle.js"></script>
  
  
  
  <link rel="shortcut icon" href="/uutiset/public/img/favicon_v1.ico" />
  <link rel="apple-touch-icon" href="/uutiset/public/img/yle-uutiset-57px.png">
  <link rel="apple-touch-icon" sizes="72x72" href="/uutiset/public/img/yle-uutiset-72px.png">
  <link rel="apple-touch-icon" sizes="114x114" href="/uutiset/public/img/yle-uutiset-114px.png">
  <link rel="apple-touch-icon" sizes="144x144" href="/uutiset/public/img/yle-uutiset-144px.png">
  <link rel="canonical" href="https://yle.fi/uutiset/3-10793809" />
  
    <style>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</style>
  
  <link rel="stylesheet" type="text/css" href="/uutiset/assets/1.0.5753-styles.css" />
</head>
<body>
  <div class="yle__skipNavigation" style="height: 10px; left: -100%; overflow: hidden; position: absolute; top: auto; width: 10px;">
    <ul>
        <li>
          <a href="#yle__contentAnchor">Hyppää sisältöön</a>
        </li>
    </ul>
  </div>
  <div class="yle__headerWrapper">
    <header role="banner" class="yle-header yle-header-lang-fi">
  <div class="yle-header-container">
    <figure class="yle-header-logo">
      <a id="yle-header-main-link-ylefi" tabindex="0" role="link" href="https://yle.fi">yle.fi</a>
    </figure>
    <nav class="yle-header-navigation">
      
        <a id="yle-header-main-link--uutiset" tabindex="0" role="link" href="https://yle.fi/uutiset">Uutiset</a>
      
        <a id="yle-header-main-link--areena" tabindex="0" role="link" href="https://areena.yle.fi/tv">Areena</a>
      
        <a id="yle-header-main-link--urheilu" tabindex="0" role="link" href="https://yle.fi/urheilu">Urheilu</a>
      
    </nav>
    <input type="checkbox" id="yle-header-navigation-toggler" />
    <span class="yle-header-megamenu-wrapper">
      <label role="button" tabindex="0" class="yle-header-navigation-toggler-text" for="yle-header-navigation-toggler">Valikko</label>
      <nav class="yle-header-megamenu">
        <ul>
        
          <li class="yle-header-main-link">
            <a id="yle-header-megamenu-main-link--uutiset" tabindex="0" role="link" href="https://yle.fi/uutiset">Uutiset</a>
          </li>
        
          <li class="yle-header-main-link">
            <a id="yle-header-megamenu-main-link--areena" tabindex="0" role="link" href="https://areena.yle.fi">Areena</a>
          </li>
        
          <li class="yle-header-main-link">
            <a id="yle-header-megamenu-main-link--urheilu" tabindex="0" role="link" href="https://yle.fi/urheilu">Urheilu</a>
          </li>
        
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--saa" class="yle-header-megamenu-link" role="link" href="https://yle.fi/saa/">Sää</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--teksti-tv" class="yle-header-megamenu-link" role="link" href="https://yle.fi/aihe/tekstitv">Teksti-TV</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--elava-arkisto" class="yle-header-megamenu-link" role="link" href="https://yle.fi/aihe/elava-arkisto">Elävä arkisto</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--lapset" class="yle-header-megamenu-link" role="link" href="https://yle.fi/aihe/lapset">Lapset</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--radio" class="yle-header-megamenu-link" role="link" href="https://areena.yle.fi/radio">Radio</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--radio-opas" class="yle-header-megamenu-link" role="link" href="https://areena.yle.fi/radio/opas">Radio-opas</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--tv-opas" class="yle-header-megamenu-link" role="link" href="https://areena.yle.fi/tv/opas">TV-opas</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--suorat" class="yle-header-megamenu-link" role="link" href="https://areena.yle.fi/tv/suorat/yle-tv1">Katsele TV:tä</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--oppiminen" class="yle-header-megamenu-link" role="link" href="https://yle.fi/aihe/oppiminen">Oppiminen</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--kulttuuri" class="yle-header-megamenu-link" role="link" href="https://yle.fi/aihe/kulttuuri">Kulttuuri</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--luonto" class="yle-header-megamenu-link" role="link" href="https://yle.fi/aihe/luonto">Luonto</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--tiede" class="yle-header-megamenu-link" role="link" href="https://yle.fi/aihe/tiede">Tiede</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--svenska" class="yle-header-megamenu-link" role="link" href="https://svenska.yle.fi">Svenska</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--news" class="yle-header-megamenu-link" role="link" href="https://yle.fi/uutiset/osasto/news/">News</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--novosti" class="yle-header-megamenu-link" role="link" href="https://yle.fi/uutiset/osasto/novosti/">Novosti</a>
          </li>
        
          <li>
            <a tabindex="-1" id="yle-header-megamenu-link--sapmi" class="yle-header-megamenu-link" role="link" href="https://yle.fi/uutiset/osasto/sapmi/">Sápmi</a>
          </li>
        
        </ul>
      </nav>
    </span>

    <div class="yle-header-actions">
      <div class="yle-header-action yle-header-action-search">
        <form novalidate method="get" action="https://haku.yle.fi/" class="yle-header-search-form">
          <input type="hidden" name="language" value="fi"/>
          <input type="hidden" name="uiLanguage" value="fi"/>
          <input
            tabindex="0"
            class="yle-header-search-input"
            name="query" type="text"
            placeholder="Hae"
            autocomplete="off"
            spellcheck="false"
            dir="auto"
            required
            aria-label="Haku"
          />
          <button tabindex="0" class="yle-header-search-submit" type="submit" title="Hae">Hae</button>
        </form>
      </div>
      <div class="yle-header-action yle-header-action-tunnus">
        <div class="yle-header-action-login">
          <button class="yle-header-tunnus-login" tabindex="0">Kirjaudu</button>
        </div>
        <div class="yle-header-action-open-tunnus-menu">
          <button class="yle-header-tunnus-menu-open">
            <span class="initials"></span>
          </button>
        </div>
        <nav aria-hidden="true" class="yle-header-tunnus-menu">
          <ul>
            <li>
              <a role="link" href="https://tunnus.yle.fi/#omat-tiedot" class="yle-header-tunnus-menu-select-profile" data-hj-masked>Omat tiedot</a>
            </li>
            <li>
              <button class="yle-header-tunnus-menu-select-logout">Kirjaudu ulos</button>
            </li>
          </ul>
        </nav>
      </div>
    </div>
  </div>
</header>
<style type="text/css">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</style><script type="text/javascript">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</script>
  </div>
  <div id="app"><div class="yle__app" data-reactroot=""><nav class="yle__navigation"><div class="yle__navigation__wrap"><ul class="yle__navigation__list yle__navigation__list--hideOverflow"><li class="yle__navigation__list__item yle__navigation__list__item--main"><a class="yle__navigation__list__item__link--main yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--etusivu" href="/uutiset"><img src="/uutiset/public/img/uutiset.svg" class="yle__navigation__list__item__link__image" alt="Uutiset"/></a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--tuoreimmat" href="/uutiset/tuoreimmat">Tuoreimmat</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a href="https://yle.fi/urheilu" class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--urheilu">Urheilu</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a href="https://yle.fi/saa" class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--saa">Sää</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--kotimaa" href="/uutiset/18-34837">Kotimaa</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--ulkomaat" href="/uutiset/18-34953">Ulkomaat</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--talous" href="/uutiset/18-204933">Talous</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--politiikka" href="/uutiset/18-220306">Politiikka</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--kulttuuri" href="/uutiset/18-208149">Kulttuuri</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--kolumnit" href="/uutiset/18-215844">Kolumnit</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--luonto" href="/uutiset/18-215452">Luonto</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--tiede" href="/uutiset/18-212923">Tiede</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--terveys" href="/uutiset/18-209306">Terveys</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--viihde" href="/uutiset/18-205614">Viihde</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--liikenne" href="/uutiset/18-217946">Liikenne</a></li><li class="yle__navigation__list__item yle__navigation__list__item--main yle__navigation__list__item--hideable"><a class="yle__navigation__list__item__link yle__borderColorHover yle__borderColorHover--blogit" href="/uutiset/18-35466">Blogit</a></li><li class="yle__navigation__list__item yle__navigation__list__item--sections"><a class="yle__navigation__list__item__link" href="javascript:;"><span class="yle__navigation__list__item__link__more"><span class="yle__navigation__list__item__link__text">Lisää</span><span class="yle__navigation__list__item__link__icon icon-angle-down"></span></span><img src="/uutiset/public/img/bars-v2.svg" class="yle__navigation__list__item__link__barmenu"/></a><div class="yle__navigation__list__item__content"><ul class="yle__navigation__list"><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset">Etusivu</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/tuoreimmat">Tuoreimmat</a></li><li class="yle__navigation__list__item"><a href="https://yle.fi/urheilu" class="yle__navigation__list__item__link">Urheilu</a></li><li class="yle__navigation__list__item"><a href="https://yle.fi/saa" class="yle__navigation__list__item__link">Sää</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-34837">Kotimaa</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-34953">Ulkomaat</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-204933">Talous</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-220306">Politiikka</a></li></ul><ul class="yle__navigation__list"><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-208149">Kulttuuri</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-215844">Kolumnit</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-215452">Luonto</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-212923">Tiede</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-209306">Terveys</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-205614">Viihde</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-217946">Liikenne</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-35466">Blogit</a></li></ul><ul class="yle__navigation__list"><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-38128">Uutiset Viittomakielellä</a></li><li class="yle__navigation__list__item"><a href="https://yle.fi/uutiset/osasto/selkouutiset/" class="yle__navigation__list__item__link">Uutiset Selkosuomeksi</a></li><li class="yle__navigation__list__item"><a href="https://yle.fi/uutiset/osasto/news/" class="yle__navigation__list__item__link">News in English</a></li><li class="yle__navigation__list__item"><a href="https://yle.fi/uutiset/osasto/novosti/" class="yle__navigation__list__item__link">Novosti Yle</a></li><li class="yle__navigation__list__item"><a href="https://svenska.yle.fi" class="yle__navigation__list__item__link">Svenska Yle</a></li><li class="yle__navigation__list__item"><a href="https://yle.fi/uutiset/osasto/sapmi/" class="yle__navigation__list__item__link">Yle Sápmi</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-44136">Yle Uudizet karjalakse</a></li><li class="yle__navigation__list__item"><a href="https://yle.fi/uutiset/osasto/uutisluokka/" class="yle__navigation__list__item__link">Yle Uutisluokka</a></li></ul><ul class="yle__navigation__list"><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-111571">A-teema</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-224166">Aamu-tv</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-35665">A-studio</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-109495">Perjantai</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/18-182026">Puoli seitsemän</a></li><li class="yle__navigation__list__item"><a href="https://yle.fi/tekstitv/" class="yle__navigation__list__item__link">Teksti-TV</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/rss">RSS-syötteet</a></li><li class="yle__navigation__list__item"><a class="yle__navigation__list__item__link" href="/uutiset/yhteystiedot">Yhteystiedot</a></li></ul></div></li></ul></div></nav><div><div class="article__background"><img class="article__background__image" src="//images.cdn.yle.fi/image/upload/w_750,h_500,f_auto,fl_lossy,q_auto:eco,e_blur:5000/13-3-10794153.jpg"/><div class="article__background__gradient"></div></div><div id="yle__section--article" class="yle__section yle__section--article"><nav class="yle__articlePage__breadcrumb" itemscope="" itemType="http://data-vocabulary.org/Breadcrumb"><ul><li><a href="https://yle.fi" itemProp="url"><span itemProp="title">yle.fi</span></a></li><li><a href="https://yle.fi/uutiset" itemProp="url"><span itemProp="title">Uutiset</span></a></li><li><a href="https://yle.fi/uutiset/18-140043" itemProp="url"><span itemProp="title">Huawei</span></a></li></ul></nav><div class="yle__layout"><div class="yle__articlePage yle__column--left yle__column yle__column--wide" id="yle__contentAnchor"><div class="yle__loadIndicator"></div><article id="yle__article--testCaseA" class="yle__article yle__article--testCaseA" itemType="http://schema.org/Article" itemscope=""><div class="yle__article__header"><div><h1 class="yle__article__heading yle__article__heading--h1" itemProp="name">Huawei rauhoittelee huolestuneita: Gmailia voi käyttää kuten ennenkin, tietoturvapäivitykset eivät lopu –​ 5 kysymystä puhelinkiistasta</h1><p class="yle__article__paragraph">Huawei vakuuttaa, että Googlen sovelluksia voi käyttää koko puhelimen eliniän ajan. Puhelinmyyjän ei tarvitse vastaanottaa virheetöntä puhelinta ja palauttaa rahoja, tulkitsee operaattoreita edustava Ficom.</p><div class="yle__article__header__meta"><a class="yle__article__listItem__subjectLink" href="/uutiset/18-140043"><span class="yle__subject yle__borderColor yle__borderColor--huawei">Huawei</span></a><div class="yle__article__date"><span class="yle__article__date--published">21.5.2019 klo 17:33</span></div></div><figure class="yle__article__figure yle__article__figure--image" itemProp="image" itemscope="" itemType="http://schema.org/Photograph"><div class="yle__article__figure__placeholder" style="height:0;padding-bottom:66.66666666666667%" itemProp="image"><img class="yle__article__figure__image" src="//images.cdn.yle.fi/image/upload//w_1200,h_800,f_auto,fl_lossy,q_auto:eco/13-3-10794153.jpg" alt="Podcast meneillään älykännyssä.   "/></div><figcaption class="yle__article__figure__caption"><div class="yle__article__figure__caption__wrapper"><span class="yle__article__figure__caption__text" itemProp="description">Honor-tuotemerkin tämän kevään malli. </span><span class="yle__article__figure__caption__source" itemProp="copyrightHolder">Massimiliano Finzi / AOP</span></div></figcaption></figure></div><div class="yle__article__header__grouper"><div class="yle__article__header__grouper__content"><div class="yle__article__header__authors"><div class="yle__article__authors"><div class="yle__article__author" itemProp="author" itemscope="" itemType="http://schema.org/Person"><figure class="yle__article__author__figure"><img src="//images.cdn.yle.fi/image/upload/w_60,h_60,c_thumb,r_max/13-3-9039787.jpg" itemProp="image" width="60" height="60" alt=""/></figure><div class="yle__article__author__info"><div class="yle__article__author__info__name"><span class="yle__article__author__name__text" itemProp="name">Stina Brännare</span></div><div class="yle__article__author__description"></div></div></div></div></div><div class="yle__article__header__shareButtons"><div class="yle__article__shareButtons"><div class="yle__article__shareButton yle__article__shareButton--facebook-circled yle__article__shareButton--facebook-color-brand"><a class="yle__article__shareButton__icon yle__article__icon--facebook-circled" href=""><span class="yle__accessibilityText">Jaa artikkeli Facebookissa</span></a><span class="yle__article__shareButton__count">24</span></div><div class="yle__article__shareButton yle__article__shareButton--twitter-circled yle__article__shareButton--twitter-color-brand"><a class="yle__article__shareButton__icon yle__article__icon--twitter-circled" href=""><span class="yle__accessibilityText">Jaa artikkeli Twitterissä</span></a><span class="yle__article__shareButton__count"></span></div><div class="yle__article__shareButton yle__article__shareButton--whatsapp-circled yle__article__shareButton--whatsapp-color-brand"><a class="yle__article__shareButton__icon yle__article__icon--whatsapp-circled" href=""><span class="yle__accessibilityText">Jaa artikkeli Whatsapissa</span></a><span class="yle__article__shareButton__count"></span></div></div></div></div></div></div><div class="yle__article__content"><p class="yle__article__paragraph">Suomen Huawei rauhoittelee kuluttajia ja operaattoreita paljon kohua aiheuttaneesta kiistasta kiinalaisyhtiön ja teknologiayhtiö Googlen välillä. </p><p class="yle__article__paragraph">Eilen haastatellut asiantuntijat arvioivat, että kuluttajille <a class="yle__article__link" href="https://yle.fi/uutiset/3-10792611">Googlen </a>päivitysten katkaiseminen voi merkitä tietoturvariskiä tai että Googlen päivitykset Huawei-laitteisiin yksinkertaisesti jääävät saamatta. </p><p class="yle__article__paragraph">Tänään Yhdysvaltain hallinnon päätöksestä alkanut suurvaltojen kauppasodasta kertova kiista sai uusia käänteitä: Yhdysvaltain hallinto ilmoitti antavansa kolmen kuukauden <a class="yle__article__link" href="https://yle.fi/uutiset/3-10793065">lisäajan</a> päätökselle, joka lopettaa yhteistyön Huawein ja amerikkalaisen Googlen välillä. </p><p class="yle__article__paragraph">Presidentti <strong class="yle__article__strong">Donald Trumpin</strong> määräämän kiellon sisältöä ei ole tarkoitus muuttaa. Trump on asettanut Huawein kieltolistalle, joka estää sitä ostamasta yhdysvaltalaista tekniikkaa ilman erillistä hyväksyntää. Päätöstä on perusteltu turvallisuussyillä.</p><p class="yle__article__paragraph">Kysyimme Suomen Huaweilta puhelinten tilanteesta nyt, Yhdysvaltain myöntämän vientikiellon lykkäyksen takia. Vastaukset on lähettänyt Suomen ja Baltian Huawein yhteiskuntasuhde- ja viestintäjohtaja <strong class="yle__article__strong">Hennariikka Andersson</strong>. </p><p class="yle__article__paragraph">Samat kysymykset esitettiin teleoperaattoreiden edustajalle, eli Tietoliikenteen ja tietotekniikan keskusliiton Ficomin toimitusjohtajalle <strong class="yle__article__strong">Elina Ussalle</strong>. Ficom vastasi kahteen kysymykseen. </p><p class="yle__article__paragraph"><strong class="yle__article__strong">1. Jos olen juuri ostanut Huawei- tai Honor-puhelimen, kuinka kauan siinä toimivat tietyt palvelut, kuten Gmail ja Google play -kauppa?</strong></p><p class="yle__article__paragraph"><strong class="yle__article__strong">Huawei</strong>: Kaikki olemassa olevat puhelinmallit jatkavat Googlen palveluiden käyttöä normaalisti koko elinkaarensa ajan. Gmailia, YouTubea, Google Play -kauppaa ja muita Googlen sovelluksia voi käyttää kuten aina ennenkin. </p><p class="yle__article__paragraph"><strong class="yle__article__strong">2. Joudunko jossain vaiheessa itse päivittämään tietoturvapäivityksiä, jotka ovat esim. uusia kiinalaisten eurooppalaisia puhelimia varten tehtyjä versioita?</strong></p><p class="yle__article__paragraph"><strong class="yle__article__strong">Huawei:</strong> Kuluttajan ei tarvitse itse tehdä sen enempää kuin tähänkään asti saadakseen tietoturvapäivitykset laitteisiinsa. Huawein ja Honorin kaikki puhelimet ovat nyt ja jatkossa tietoturvallisia, tästä ei tingitä. </p><p class="yle__article__paragraph">Huawei tarjoaa tietoturvapäivitykset ja huoltopalvelut kaikille Huawei- ja Honor-älypuhelimien ja -tablettien ostajille nyt ja jatkossa. Kaikissa myytävissä puhelimissa ja tableteissa on esiasennettuna kolmannen osapuolen Avast-lisätietoturvaohjelmisto. </p><p class="yle__article__paragraph">Tämä on esimerkki siitä, että kuluttaja voi myös käyttää ilmaisia verkossa löytyviä tietoturvaohjelmia lisänä, jos haluaa. Näitä voi ladata vapaasti sovelluskaupasta. </p><p class="yle__article__paragraph"><strong class="yle__article__strong">3. Onko mahdollista, että ostaja voisi palauttaa puhelinkauppiaalle jo hankkimansa Huawei-puhelimen? Jos puhelimessa ei ole samoja ominaisuuksia kuin ostaessa? Jos siihen tulee kolmen kuukauden jälkeen muutoksia?</strong> </p><p class="yle__article__paragraph"><strong class="yle__article__strong">Huawei</strong>: Kolmen kuukauden siirtymäajalla ei ole vaikutusta jo olemassa oleviin puhelimiin ja tabletteihin.</p><p class="yle__article__paragraph">Kaikki Huawein ja Honorin olemassa olevat puhelinmallit jatkavat Googlen palveluiden käyttöä täysin normaalisti koko elinkaarensa ajan. Eli käytännössä niin kauan kuin puhelin on käyttökelpoinen. </p><p class="yle__article__paragraph">Puhelimissa toimii jatkossakin samat ominaisuudet kuin ostohetkellä. </p><p class="yle__article__paragraph"><strong class="yle__article__strong">Ficom:</strong> Myyjällä ei ole välitöntä velvollisuutta vastaanottaa virheetöntä luuria ja palauttaa rahoja. Tietoa ostetun puhelimen virheestä ei ole, eikä myöskään siitä, mitä ominaisuuksia ei ole jatkossa tai voidaanko muuttuneet ominaisuudet korvata jollain toisella. </p><p class="yle__article__paragraph">Tällä hetkellä tilanne on vielä siinä määrin epämääräinen, ja tietoa asiasta riittämättömästi, jotta voitaisiin tehdä selkeitä linjauksia.</p><p class="yle__article__paragraph"><strong class="yle__article__strong">4. Neuvotteleeko Huawei Googlen kanssa uudesta tilanteesta?</strong> </p><p class="yle__article__paragraph"><strong class="yle__article__strong">Huawei:</strong> Yritämme yhdessä Googlen kanssa ratkaista annettujen raamien puitteissa tilannetta, joka ei ole johtunut kummastakaan osapuolesta vaan kolmannesta tahosta. Yhteinen tahtotila on olemassa, ja toivomme Huaweilla, että ratkaisu saataisiin aikaan. </p><p class="yle__article__paragraph"><strong class="yle__article__strong">5. Vaikuttaako tämä Huawein 5G-verkkojen toimintaan Suomessa? Huaweihan tekee yhteistyötä kaikkien Suomessa toimivien operaattoreiden kanssa.</strong> </p><p class="yle__article__paragraph"><strong class="yle__article__strong">Huawei:</strong> Tilanne ei vaikuta Huawein kykyyn toimittaa 5G-verkkoja Suomessa lyhyellä eikä pitkällä tähtäimellä. Sen sijaan isommassa kuvassa tilanne aiheuttaa epävarmuutta koko alalle, sillä kaikki toimijat odottavat tilanteen rauhoittumista.</p><p class="yle__article__paragraph"><strong class="yle__article__strong">Ficom:</strong> Huawei on Suomessa yksi teleyritysten laitetoimittajakumppaneista Nokian ja Ericssonin ohella. Kaikkien suomalaisten isojen operaattoreiden verkoissa käytetään Huaweinkin teknologiaa.</p><p class="yle__article__paragraph">5G-verkon rakentavat teleyritykset. Tarvittavien verkkolaitteiden toimittamisesta vastaa niiden valmistaja.</p><p class="yle__article__paragraph">Teleyrityksillä ei ole tietoa eri laiteosien saatavuuteen liittyvistä kysymyksistä. Viestintäverkot rakennetaan aina alan standardeihin, tietoturvavaatimuksiin ja parhaisiin käytäntöihin nojaten. </p><p class="yle__article__paragraph">Tilannetta seurataan ja vuoropuhelua käydään myös viranomaisten kanssa aktiivisesti.</p><p class="yle__article__paragraph"><strong class="yle__article__strong">Lue myös:</strong> </p><p class="yle__article__paragraph"><a class="yle__article__link" href="https://yle.fi/uutiset/3-10792611">Google-päivitysten</a> katkaiseminen Huaweille hämmentää suomalaisia kännykänkäyttäjiä: &quot;Tähän Trump varmaan pyrkikin&quot;</p><p class="yle__article__paragraph"><a class="yle__article__link" href="https://yle.fi/uutiset/3-10793065">Yhdysvallat</a> lykkää kolme kuukautta vientikieltoa </p><p class="yle__article__paragraph"> <a class="yle__article__link" href="https://yle.fi/uutiset/3-10791822">Suomalaisasiantuntija</a> kommentoi Huawein ja USA:n tietoverkkokiistaa: &quot;Syyttömiin käyttäjiin iskevä temppu on raju toimenpide&quot;</p></div><div class="Newsletter__container___15A2k"><img class="Newsletter__icon___3h3Ls" src="/uutiset/public/img/newsletter/kirjeet-icon_v2.svg"/><div><h2 class="Newsletter__heading___3DYvl">Tilaa Ylen uutiskirjeitä!</h2><p class="Newsletter__body___tVDbx">Saat Ylen parhaat sisällöt suoraan sähköpostiisi! Tilaa niin monta kirjettä kuin haluat!</p><a id="uutiset-ylefikirjeet-banner" class="Newsletter__kirjeetLink___3G_sz" href="https://kirjeet.yle.fi" target="_blank" rel="noopener noreferrer">Siirry tilaamaan</a></div></div><div class="yle__article__footer"><div class="yle__article__footer__tools"><a class="yle__article__clickable yle__article__footer__button"><span>Lisää aiheesta </span></a><a class="yle__article__clickable yle__article__footer__button"><span>Ota yhteyttä</span></a></div><div class="yle__article__footer__content yle__article__footer__content--closed"><div class="yle__article__footer__subjects"><a class="yle__article__listItem__subjectLink" href="/uutiset/18-140043"><span class="yle__subject yle__borderColor yle__borderColor--huawei">Huawei</span></a><a class="yle__article__listItem__subjectLink" href="/uutiset/18-204933"><span class="yle__subject yle__borderColor yle__borderColor--talous">talous</span></a><a class="yle__article__listItem__subjectLink" href="/uutiset/18-44882"><span class="yle__subject yle__borderColor yle__borderColor--ficom_ry">Ficom ry</span></a><a class="yle__article__listItem__subjectLink" href="/uutiset/18-36501"><span class="yle__subject yle__borderColor yle__borderColor--matkapuhelimet_ja_mobiililaitteet">Matkapuhelimet ja mobiililaitteet</span></a><a class="yle__article__listItem__subjectLink" href="/uutiset/18-36171"><span class="yle__subject yle__borderColor yle__borderColor--puhelinvalmistajat">Puhelinvalmistajat</span></a><a class="yle__article__listItem__subjectLink" href="/uutiset/18-214904"><span class="yle__subject yle__borderColor yle__borderColor--puhelimet">puhelimet</span></a><a class="yle__article__listItem__subjectLink" href="/uutiset/18-218706"><span class="yle__subject yle__borderColor yle__borderColor--tietoturva">tietoturva</span></a></div></div></div></article><section class="yle__ylefiPublicationStories yle__newsList__sectionList__section yle__newsList__sectionList__section--ylefiPublicationStories"><div class="yle__newsList__sectionList__section__header"><a class="yle__ylefiPublicationStories__link" href="https://yle.fi"><h1 class="yle__heading yle__heading--h1">Yle.fi-etusivulla juuri nyt:</h1></a></div><div class="yle__newsList__sectionList__section__articles"><article class="yle__article__listItem yle__article__listItem--ylefiPublicationStory" style="background-color:#f7edcb"><a class="yle__ylefiPublicationStories__link" href="https://yle.fi/uutiset/3-10793607"><div class="yle__article__listItem__container"><figure class="yle__article__listItem__figure"><div class="yle__article__listItem__figure__placeholder"><img class="yle__article__listItem__figure__image" src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10793926.jpg" data-src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10793926.jpg" alt=""/></div></figure><div class="yle__article__listItem__textualContent"><span class="yle__article__listItem__subject" style="color:#ffffff;background-color:#bc1953">Kiharat hiukset</span><h3 class="yle__article__listItem__title" style="color:#000000">&quot;Paljon on ollut puheita pehmeästä parrasta&quot;</h3><h3 class="yle__article__listItem__title" style="color:#000000">Curly girl tyhjensi kauppojen hyllyt – miehetkin kihartavat nyt partojaan</h3></div></div></a></article><article class="yle__article__listItem yle__article__listItem--ylefiPublicationStory" style="background-color:#222e47"><a class="yle__ylefiPublicationStories__link" href="https://yle.fi/aihe/artikkeli/2019/05/21/suuri-striimaussota-spotify-apple-ja-amazon-kilpailevat-kuunteluista-ja-se"><div class="yle__article__listItem__container"><figure class="yle__article__listItem__figure"><div class="yle__article__listItem__figure__placeholder"><img class="yle__article__listItem__figure__image" src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/39-4757255ac3878ec832f.jpg" data-src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/39-4757255ac3878ec832f.jpg" alt=""/></div></figure><div class="yle__article__listItem__textualContent"><span class="yle__article__listItem__subject" style="color:#000000;background-color:#c7f0d8">Ylex</span><h3 class="yle__article__listItem__title" style="color:#ffffff">Suuri striimaussota: Spotify, Apple ja Amazon kilpailevat kuunteluista, ja se tulee muuttamaan tapamme kuunnella musiikkia</h3></div></div></a></article><article class="yle__article__listItem yle__article__listItem--ylefiPublicationStory" style="background-color:#673bb8"><a class="yle__ylefiPublicationStories__link" href="https://yle.fi/uutiset/3-10793809"><div class="yle__article__listItem__container"><figure class="yle__article__listItem__figure"><div class="yle__article__listItem__figure__placeholder"><img class="yle__article__listItem__figure__image" src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10794153.jpg" data-src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10794153.jpg" alt=""/></div></figure><div class="yle__article__listItem__textualContent"><span class="yle__article__listItem__subject" style="color:#000000;background-color:#e0d2f8">Huawei</span><h3 class="yle__article__listItem__title" style="color:#ffffff">Huawei rauhoittelee huolestuneita: Gmailia voi käyttää kuten ennenkin, tietoturvapäivitykset eivät lopu –​ 5 kysymystä puhelinkiistasta</h3></div></div></a></article><article class="yle__article__listItem yle__article__listItem--ylefiPublicationStory" style="background-color:#ffffff"><a class="yle__ylefiPublicationStories__link" href="https://yle.fi/urheilu/3-10794667"><div class="yle__article__listItem__container"><figure class="yle__article__listItem__figure"><div class="yle__article__listItem__figure__placeholder"><img class="yle__article__listItem__figure__image" src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10794230.jpg" data-src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10794230.jpg" alt=""/></div></figure><div class="yle__article__listItem__textualContent"><span class="yle__article__listItem__subject" style="color:#ffffff;background-color:#0678b4">Jääkiekon mm 2019</span><h3 class="yle__article__listItem__title" style="color:#000000">Leijonien hyökkääjältä paljonpuhuva tunnustus Saksa-tappiosta: &quot;Emme lyöneet kaikkea likoon&quot;</h3></div></div></a></article></div></section></div><div class="yle__column yle__column--narrow yle__column--right yle__newsList__sidebar"><div class="yle__newsList__sidebar__wrapper yle__newsList__sidebar__topnews"><div class="yle__newsList__sidebar__section__header"><h1 class="yle__heading yle__heading--h1">Pääuutiset</h1></div><div id="yle__newsList__sidebarNewsList--topNews--testCaseA" class="yle__newsList__sidebar__container"><article class="yle__article__listItem--sizeL yle__article__listItem yle__article__listItem__layout--textContentBelowFigure yle__borderColor yle__borderColor--huawei"><div class="yle__article__listItem__container"><a class="yle__article__listItem__link" href="/uutiset/3-10793809"><figure class="yle__article__listItem__figure"><div class="yle__article__listItem__figure__placeholder"><img class="yle__article__listItem__figure__image" src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10794153.jpg" data-src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10794153.jpg" alt=""/></div></figure><div class="yle__article__listItem__textualContent"><h1 class="yle__article__listItem__title">Huawei rauhoittelee huolestuneita: Gmailia voi käyttää kuten ennenkin, tietoturvapäivitykset eivät lopu –​ 5 kysymystä puhelinkiistasta</h1><p class="yle__article__listItem__lead">Huawei vakuuttaa, että Googlen sovelluksia voi käyttää koko puhelimen eliniän ajan. Puhelinmyyjän ei tarvitse vastaanottaa virheetöntä puhelinta ja palauttaa rahoja, tulkitsee operaattoreita edustava Ficom.</p><span class="yle__article__listItem__meta"><span class="yle__subject yle__borderColor yle__borderColor--huawei">Huawei</span><time class="yle__article__listItem__meta__published" dateTime="2019-05-21T17:33:10+0300">17:33</time></span></div></a></div></article><article class="yle__article__listItem--sizeL yle__article__listItem yle__article__listItem__layout--textContentBelowFigure yle__borderColor yle__borderColor--sauli_niinisto"><div class="yle__article__listItem__container"><a class="yle__article__listItem__link" href="/uutiset/3-10793666"><figure class="yle__article__listItem__figure"><div class="yle__article__listItem__figure__placeholder"><img class="yle__article__listItem__figure__image" src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/39-5600135ccae12f2309e.jpg" data-src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/39-5600135ccae12f2309e.jpg" alt=""/></div></figure><div class="yle__article__listItem__textualContent"><h1 class="yle__article__listItem__title">Presidentti Niinistö haluaa pitää koko maan asuttuna: &quot;On välttämätöntä, että maaseudulla on nuorta väkeä&quot;</h1><p class="yle__article__listItem__lead">Presidentin mukaan alueellinen eriarvoisuus on ikuisuusaihe.</p><span class="yle__article__listItem__meta"><span class="yle__subject yle__borderColor yle__borderColor--sauli_niinisto">Sauli Niinistö</span><time class="yle__article__listItem__meta__published" dateTime="2019-05-21T18:30:00+0300">18:30</time></span></div></a></div></article><article class="yle__article__listItem--sizeL yle__article__listItem yle__article__listItem__layout--textContentBelowFigure yle__borderColor yle__borderColor--vaikuttaminen yle__article__listItem--ulkomaat"><div class="yle__article__listItem__container"><a class="yle__article__listItem__link" href="/uutiset/3-10794424"><figure class="yle__article__listItem__figure"><div class="yle__article__listItem__figure__placeholder"><img class="yle__article__listItem__figure__image" src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10794507.jpg" data-src="//images.cdn.yle.fi/image/upload/w_369%2Ch_207%2Cc_fill%2Cg_faces%2Cf_auto%2Cfl_lossy%2Cq_auto%3Aeco/13-3-10794507.jpg" alt=""/></div></figure><div class="yle__article__listItem__textualContent"><h1 class="yle__article__listItem__title">NBC: Venäläiset toimijat vielä viime vuonnakin juonivat sisäisen levottomuuden lietsomista Yhdysvalloissa – esillä rotuvihan nostatus</h1><p class="yle__article__listItem__lead">Vaikutusyrityksillä olisi pyritty heikentämään Yhdysvaltojen koskemattomuutta sekä sen sotilaallista ja taloudellista voimaa. </p><span class="yle__article__listItem__meta"><span class="yle__subject yle__borderColor yle__borderColor--vaikuttaminen">vaikuttaminen</span><time class="yle__article__listItem__meta__published" dateTime="2019-05-21T16:48:37+0300">16:48</time></span></div></a></div></article></div></div></div></div></div></div></div></div>
  <script type="text/javascript">
    var IS_PICTURE_SUPPORTED = typeof window !== 'undefined' && 'HTMLPictureElement' in window
    if (!IS_PICTURE_SUPPORTED) {
      document.querySelector('body').classList.add('no-picture')
    }
  </script>
  <script type="text/javascript">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</script>
  <script type="text/javascript">
    (function(b,r,a,n,c,h,_,s,d,k){if(!b[n]||!b[n]._q){for(;s<_.length;)c(h,_[s++]);d=r.createElement(a);d.async=1;d.src="https://cdn.branch.io/branch-latest.min.js";k=r.getElementsByTagName(a)[0];k.parentNode.insertBefore(d,k);b[n]=h}})(window,document,"script","branch",function(b,r){b[r]=function(){b._q.push([r,arguments])}},{_q:[],_v:1},"addListener applyCode autoAppIndex banner closeBanner closeJourney creditHistory credits data deepview deepviewCta first getCode init link logout redeem referrals removeListener sendSMS setBranchViewData setIdentity track validateCode trackCommerceEvent".split(" "), 0);
    branch.init(CLIENT_CONFIG.branchAppKey);
  </script>
  <script type="text/javascript" src="/uutiset/assets/1.0.5753-bundle.js"></script>
  <script type="text/javascript" src="https://player-v2.yle.fi/embed.js"></script>
  <script type="text/javascript">
    dataLayer = [{
      'ylefi-uutiset': CLIENT_CONFIG.env
    }];
  </script>
  <!-- Google Tag Manager -->
  <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-T3LL7L"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-T3LL7L');</script>
  <!-- End Google Tag Manager -->
  
    <script type="text/javascript" src="https://tunnus-sdk.yle.fi/v1/index.js"></script>
  

  
    <script type="text/javascript" src="https://comments.yle.fi/versions/1.2.730/yle-comments-plugin.js"></script>
  
</body>
</html>
